1. 心意SEO优化首页
  2. 云服务器

wordpress IP验证不当_阿里云服务器漏洞的解决方法

漏洞说明介绍

阿里云服务器的漏洞提示为:wordpress IP验证不当漏洞

简介

wordpress /wp-includes/http.php文件中的wp_http_validate_url函数对输入IP验证不当,导致黑客可构造类似
于012.10.10.10这样的畸形IP绕过验证,进行SSRF。

推荐修复方案

方案一:使用云盾自研补丁进行一键修复;
方案二:更新该软件到官方最新版本或寻求该软件提供商的帮助。
注意:该补丁为云盾自研代码修复方案,云盾会根据您当前代码是否符合云盾自研的修复模式进行检测,如果您自行采取了底层/框架统一修复、或者使用了其他的修复方案,可能会导致您虽然已经修复了该漏洞,云盾依然报告存在漏洞,遇到该情况可选择忽略该漏洞提示。wordpress IP验证不当

何漏洞修复方法与步骤

上面一段介绍为漏洞的显示信息,具体修复方法见如下几点,根据步骤一步步来,修复之前切记将文件做好备份,以免造成不必要的麻烦。

1、在路径:/wwwroot/www.cxyseo.cn/wp-includes/http.php找到http.php文件,用Notepad++打开(修改之前记得先备份http.php原文件),大约在546行(不同的WordPress版本可能行数不同,你可以使用查找关键词(ctrl+F)的方法进行查找):

  • $same_host = strtolower( $parsed_home[‘host’] ) === strtolower( $parsed_url[‘host’] );
  • /*修改为*/
  • $same_host = ( strtolower( $parsed_home[‘host’] ) === strtolower( $parsed_url[‘host’] ) || ‘localhost’ == strtolower($parsed_url[‘host’]));

2、在http.php文件的大约564行:

  • if ( 127 === $parts[0] || 10 === $parts[0] || 0 === $parts[0]
  • /*修改为:*/
  • if ( 127 === $parts[0] || 10 === $parts[0] || 0 === $parts[0] || 0 === $parts[0]

验证修复结果

修改完以上内容,然后再到阿里云盾控制台重新验证一下漏洞,就会发现漏洞已经不存在了。

版权声明:本文作者:心意SEO,如若转载请注明来源。来源:https://www.cxyseo.cn/451.html

发表评论

电子邮件地址不会被公开。

联系我们

180-6978-7757

点击咨询:点击这里给我发消息

客服邮箱:kefu@cxyseo.cn

服务时间:08:30-22:00,每周一至周日,节假日无休息

QR code